To view uptime history for your instance of Canvas, click here.

Canvas Page Errors
Incident Report for Instructure
Resolved
This behavior has been resolved and Canvas is now functioning regularly.
Posted Sep 14, 2022 - 21:19 MDT
Identified
The issue has been identified, and our engineering team is now deploying a fix. We will update the status page as more information is available.
Posted Sep 14, 2022 - 21:05 MDT
Investigating
Some users may receive an error stating "currently unable to handle this request" when accessing Canvas. We are working on a resolution and will update as more information is available.
Posted Sep 14, 2022 - 20:56 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (eu-west-1).