To view uptime history for your instance of Canvas, click here.

Some users may be seeing long load times when accessing Canvas.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Nov 14, 2023 - 12:52 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2023 - 12:46 MST

Identified

The issue has been identified and our engineering team is working to resolve the slow load times.
Posted Nov 14, 2023 - 12:38 MST

Investigating

We are currently investigating this issue.
Posted Nov 14, 2023 - 12:36 MST
This incident affected: Canvas (Canvas LMS).