Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 28, 2020 - 13:30 MDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted May 28, 2020 - 13:15 MDT
Investigating
We are currently investigating this issue.
Posted May 28, 2020 - 13:09 MDT
This incident affected: Canvas (Canvas).