To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 20, 2020 - 10:53 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2020 - 10:09 MDT
Investigating
Our DevOps team is currently investigating the issue, and we'll provide an update shortly.
Posted Aug 20, 2020 - 10:04 MDT
This incident affected: Canvas (Canvas).