To view uptime history for your instance of Canvas, click here.

Canvas Data is currently loading slower than intended in the US region

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Nov 27, 2023 - 12:14 MST

Investigating

Canvas Data was originally experiencing 503 errors, this has been resolved but we are currently seeing slowness in queries currently.
Posted Nov 27, 2023 - 11:08 MST
This incident affected: AWS Region (us-east-1).