To view uptime history for your instance of Canvas, click here.

Commons is not loading in some regions
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 10:36 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2024 - 10:15 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2024 - 10:05 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2024 - 09:49 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2024 - 09:48 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 06, 2024 - 09:46 MDT
This incident affected: AWS Region (eu-west-1, us-east-1, us-west-2) and Canvas (Canvas Commons).