To view uptime history for your instance of Canvas, click here.

Extended processing time for some jobs in Canvas (SIS, content migration and notifications)
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 14:58 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2023 - 14:55 MDT
Investigating
Our engineers are currently investigating the cause of these slower than normal job processing times.
Posted Aug 24, 2023 - 14:23 MDT
This incident affected: Canvas (Canvas LMS).