To view uptime history for your instance of Canvas, click here.

Long load times
Incident Report for Instructure
Resolved
After further monitoring this server has stabalized. We will continue to monitor the issue but at this time we will be resolving the issue.
Posted Oct 15, 2018 - 17:36 MDT
Monitoring
Our engineering team was able to resolve the issue and we are currently monitoring the stability of load times. We will continue to monitor this issue.
Posted Oct 15, 2018 - 17:26 MDT
Investigating
We currently have users reporting longer than normal load times to access Canvas. This does look like it is limited to users in the US East servers.
Posted Oct 15, 2018 - 17:19 MDT
This incident affected: Canvas (Canvas LMS).