To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
The load times that were impacting some users have returned to normal. We appreciate your patience while our team looked into this.
Posted Jan 23, 2020 - 09:20 MST
Investigating
Some users are experiencing long load times when accessing Canvas. Our DevOps team is currently investigating this issue, and we'll provide an update in a few minutes.
Posted Jan 23, 2020 - 09:15 MST
This incident affected: Canvas (Canvas LMS).