To view uptime history for your instance of Canvas, click here.

Some users are experiencing errors when accessing Canvas.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 18:54 MDT

Update

We are continuing to monitor for any further issues.
Posted Mar 24, 2025 - 18:53 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 18:49 MDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 18:41 MDT

Investigating

We are currently investigating this issue.
Posted Mar 24, 2025 - 18:36 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).