To view uptime history for your instance of Canvas, click here.

A subset of users are experiencing long load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 09:53 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2020 - 09:43 MST
Investigating
A subset users are experiencing long load times or error messages when accessing Canvas. Our DevOps team are currently investigating the cause, we'll provide an update shortly.
Posted Nov 24, 2020 - 09:37 MST
This incident affected: Canvas (Canvas).