To view uptime history for your instance of Canvas, click here.

A small amount of Canvas users are experiencing slower load times than normal
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 07, 2019 - 10:20 MST
Investigating
A small number of Canvas users may be experiencing longer load times than normal. Our engineers are currently reviewing potential causes, as well as any mitigation options. We apologize for the inconvenience.
Posted Feb 07, 2019 - 09:50 MST
This incident affected: Canvas (Canvas LMS).