To view uptime history for your instance of Canvas, click here.

Some Catalog users in the DUB region may have experienced 504 errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 11:40 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 01, 2022 - 11:40 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2022 - 11:15 MDT
This incident affected: Canvas (Canvas Catalog).