To view uptime history for your instance of Canvas, click here.

Some users experiencing high load times
Incident Report for Instructure
Resolved
The load times have remained normal and the incident has been resolved.
Posted Oct 04, 2022 - 19:11 MDT
Monitoring
Our engineers have identified the cause of the page loading and implemented a fix. We are monitoring the situation to ensure load times remain normal.
Posted Oct 04, 2022 - 18:59 MDT
Investigating
Some users are experiencing higher than normal load times or Time-out Errors. Our engineers are investigating the cause of these load times.
Posted Oct 04, 2022 - 18:46 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).