To view uptime history for your instance of Canvas, click here.

Canvas Page Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 24, 2021 - 22:40 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2021 - 22:27 MDT
Identified
Our team has identified an issue that is causing a small amount of users hosted in our Singapore region to encounter page errors or slow load times when accessing Canvas. They are actively working to correct this issue.
Posted Oct 24, 2021 - 22:26 MDT
This incident affected: Canvas (Canvas LMS).