To view uptime history for your instance of Canvas, click here.

Media recording, uploading, and playback degraded for some users

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 04:26 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 04:23 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2025 - 04:12 MST

Update

We are continuing to investigate this issue.
Posted Mar 06, 2025 - 03:55 MST

Investigating

We are currently investigating this issue.
Posted Mar 06, 2025 - 03:41 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).