Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 18:06 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 17:52 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 23, 2020 - 17:46 MDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2020 - 17:42 MDT
This incident affected: Canvas (Canvas).