This issue has been resolved and all Instructure products are working as intended.
Posted Jul 16, 2026 - 06:21 MDT
Monitoring
A fix has been implemented in all regions for all affected products. We are currently monitoring the results.
Posted Jul 16, 2026 - 05:57 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 05:52 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 05:38 MDT
Update
Mastery Connect is accessible once again. Our team is monitoring it, while working on restoring other impacted services in all regions.
Posted Jul 16, 2026 - 05:26 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 05:13 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 05:03 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 04:48 MDT
Update
Canvas and our other impacted services are now accessible from our EU servers once again. Our team is monitoring this and working on restoring access to other regions as well.
Posted Jul 16, 2026 - 04:31 MDT
Update
AWS Cloudfront has a global outage. We are investigating the issue together with AWS experts. Their team is providing updates from their end here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 04:17 MDT
Identified
AWS Cloudfront has a global outage. We are investigating the issue together with AWS experts. Their team is providing updates from their end here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 04:03 MDT
Update
AWS Cloudfront has a global outage. We are investigating the issue together with AWS experts. Their team is providing updates from their end here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 03:53 MDT
Update
AWS Cloudfront has a global outage. We are investigating the issue together with AWS experts. Their team is providing updates from their end here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 03:38 MDT
Update
AWS Cloudfront has a global outage. We investigating the issue together with AWS experts. You can follow updates from their team here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 03:27 MDT
Update
AWS Cloudfront has a global outage. We investigating the issue together with AWS experts. You can follow updates from their team here: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 03:13 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 02:56 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 02:49 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 02:46 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 02:35 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 02:24 MDT
Investigating
We are currently investigating this issue.
Posted Jul 16, 2026 - 02:22 MDT
This incident affected: Canvas (Canvas LMS, Canvas Catalog, Canvas Portfolio), AWS Region (ca-central-1, eu-central-1, eu-west-1, us-east-1, us-west-2, ap-southeast-1, ap-southeast-2), and Mastery (Mastery Connect).