To view uptime history for your instance of Canvas, click here.

Issues with Rich Content Editor in Canvas
Incident Report for Instructure
Resolved
QA testing has been completed, and our engineers have deployed the fix to the live Canvas environment. Linking or embedding files and images within the Rich Content Editor is now working properly throughout all Canvas environments. Keep in mind that any new course objects added via the Rich Content Editor since 28 October (e.g. a page, the description of an assignment or quiz, etc) that displayed any of these issues may need to be edited again, and files/images re-added to that content, in order to appear correctly.
Posted Nov 03, 2017 - 16:25 MDT
Update
Our QA team has been busy testing the fix for issues with the Rich Content Editor, and is feeling confident that it will resolve these problems for Canvas users. They are preparing for the last round of testing in our Beta and Test environments. Once QA is finished with the remainder of their testing, we can apply these changes to the live Production environment as well. We'll send an update on the status of this fix by 5:00 PM Mountain Time.
Posted Nov 03, 2017 - 15:00 MDT
Identified
Our engineering team has identified the cause of the Rich Content Editor issues we mentioned yesterday, and have been working this morning to fine-tune a fix they've put together. We have our QA team ready to test the fix in a controlled environment prior to deploying it to the live production environment, to ensure the code changes in the fix do not cause any further trouble. If all goes well with testing, we'll work to have the fix deployed to production later today. We'll provide an update around 3:00 PM Mountain Time; sooner, if the fix is ready to be deployed before then.
Posted Nov 03, 2017 - 11:23 MDT
Investigating
Canvas users may be running into issues viewing or editing images and other files within their courses in Canvas, due to two separate issues with our Rich Content Editor:

* Links to files that are supported for previewing in Canvas do not show an icon to indicate that a preview is available for the file. Clicking on the link takes the user to their personal Files page to preview the file, and requires them to navigate back to their course after closing the preview.

* Images uploaded from the "Images" tab, in the content selector on the right side of the Rich Content Editor, do not show a thumbnail of the image. Only the title of the image appears. Images must be uploaded via the "Insert Image" icon in the Rich Content Editor, or users must refresh the page after uploading from the content selector, for the images to embed properly.

We apologize for any trouble these issues are causing for your users, and we're working to resolve them as soon as we can. We do not yet have a timeframe for when they will be resolved, but we'll provide an update on our progress by the end of the day tomorrow.
Posted Nov 02, 2017 - 12:22 MDT