To view uptime history for your instance of Canvas, click here.

Some users may be experiencing 'Heavy load' error messages when accessing Studio.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted May 23, 2023 - 15:43 MDT

Update

We are continuing to investigate this issue.
Posted May 23, 2023 - 15:43 MDT

Update

We are continuing to investigate this issue.
Posted May 23, 2023 - 15:31 MDT

Update

We are continuing to investigate this issue.
Posted May 23, 2023 - 15:17 MDT

Update

We are continuing to investigate this issue.
Posted May 23, 2023 - 14:52 MDT

Investigating

We are currently investigating this issue.
Posted May 23, 2023 - 14:33 MDT
This incident affected: AWS Region (us-east-1) and Canvas (Canvas Studio).