Some customers might experience low response times and page errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 01:41 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2020 - 01:18 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2020 - 01:15 MDT
Investigating
We are currently investigating this issue.
Posted Apr 02, 2020 - 00:38 MDT
This incident affected: Canvas (Canvas).