To view uptime history for your instance of Canvas, click here.

Some users may have experienced slow load times or page errors in Canvas
Incident Report for Instructure
Resolved
Our team was able to identify and resolve the load times and page errors inside of Canvas.
Posted Feb 07, 2021 - 13:30 MST
Investigating
A small amount of Canvas users are running into longer than normal load times, or 504 error messages. We are currently looking into this issue.
Posted Feb 07, 2021 - 12:51 MST
This incident affected: Canvas (Canvas LMS).