To view uptime history for your instance of Canvas, click here.

Some US based users experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Our Devops team was able to resolve the issue. Users should be able to access Canvas as intended.
Posted Mar 23, 2021 - 14:37 MDT
Investigating
We are currently working with our Devops team to figure out the cause.
Posted Mar 23, 2021 - 14:29 MDT
This incident affected: Canvas (Canvas LMS).