To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 13:40 MDT
Monitoring
A fix has been implemented and Canvas appears to be back to being fully operational. We will monitor the results and provide any updates in the next few minutes.
Posted Apr 28, 2020 - 13:21 MDT
Investigating
Some users are experiencing timeouts and page errors when attempting to access Canvas. We're currently investigating this issue, and will provide an update soon.
Posted Apr 28, 2020 - 13:07 MDT
This incident affected: Canvas (Canvas LMS).