Some users may run into slow load times or errors when accessing Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 10:48 MDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 11, 2026 - 10:40 MDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 11, 2026 - 10:02 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 11, 2026 - 08:56 MDT

Update

We are continuing to investigate this issue.
Posted Aug 11, 2026 - 08:33 MDT

Investigating

We are currently investigating this issue.
Posted Aug 11, 2026 - 08:25 MDT