To view uptime history for your instance of Canvas, click here.

Some users experienced Slowness and/or Page errors when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operations. We thank you for your patience.
Posted Aug 31, 2019 - 08:02 MDT
Monitoring
We've received reports of some users were experiencing slow load times and page errors. Our DevOps team were made aware of the situation, and has rectified the issue. We'll be monitoring the situation closely for the next few minutes.
Posted Aug 31, 2019 - 07:40 MDT
This incident affected: Canvas (Canvas LMS).