To view uptime history for your instance of Canvas, click here.

New Quizzes Unresponsive
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 20, 2022 - 11:14 MDT
Investigating
Our engineering team is investigating an issue that is causing New Quizzes to be unresponsive.
Posted Oct 20, 2022 - 11:09 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).