To view uptime history for your instance of Canvas, click here.

A subset of users are experiencing long load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Nov 14, 2020 - 20:45 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2020 - 20:33 MST
Investigating
A small subset of users are experiencing long load times or error messages when accessing Canvas. Our DevOps team are currently investigating the issue, we'll provide an update shortly.
Posted Nov 14, 2020 - 20:20 MST
This incident affected: Canvas (Canvas LMS).