To view uptime history for your instance of Canvas, click here.

Some customers might experience low response times and page errors in Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 09, 2020 - 21:32 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2020 - 21:29 MDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2020 - 21:25 MDT
This incident affected: Canvas (Canvas LMS).