To view uptime history for your instance of Canvas, click here.

Some users may experience degraded performance.
Incident Report for Instructure
Resolved
The fix our devops team put in place has fully processed and normal functionality has been restored. Thank you for your patience, we apologize for any inconvenience this has caused.
Posted Jan 22, 2019 - 21:02 MST
Monitoring
Our devops team has implemented a fix for previous issues with page load times. Unfortunately as this fix takes place some users may experience degraded performance in Canvas.
Posted Jan 22, 2019 - 20:38 MST
This incident affected: Canvas (Canvas LMS).