To view uptime history for your instance of Canvas, click here.

Phone Support Call Not Going Through
Incident Report for Instructure
Resolved
We have been informed that Zendesk voice is fully operational and that the issue has been resolved. Your users will now be able to contact us via telephone. We apologize for any inconvenience this may have caused.
Posted Nov 22, 2014 - 00:51 MST
Monitoring
Zendesk voice is currently experiencing difficulties with their phone system. This is preventing your calls from coming to us. You can still contact us through your Chat link, Help link inside Canvas, or support@instructure.com. We will keep you updated. We apologize for the inconvenience.
Posted Nov 21, 2014 - 17:21 MST