A small subset of U.S. based users are experiencing slowness or page errors when accessing Canvas
Incident Report for Canvas
Resolved
Canvas users in the U.S. were seeing intermittent page errors in Canvas. Our Operations team was able to investigate, identify, and resolve the issue. We appreciate your patience, and apologize for any inconvenience this may have caused.
Posted 3 months ago. Sep 26, 2017 - 09:21 MDT
Investigating
Canvas users in the U.S. are experiencing slowness and intermittent page errors in Canvas. Our Operations team is investigating the issue. We appreciate your patience as we work to resolve this issue as quickly as possible.
Posted 3 months ago. Sep 26, 2017 - 09:07 MDT