To view uptime history for your instance of Canvas, click here.

Slowness and Timeouts
Incident Report for Instructure
Resolved
For now, the system performance issues have subsided and Our DevOps team will continue to monitor system performance.
Posted Jun 09, 2016 - 11:04 MDT
Investigating
Some users may be experiencing slowness and possible timeout errors (white pages) in Canvas. Our DevOps team is aware of the issue and are currently working on a resolution; we'll provide an update within the next fifteen minutes.
Posted Jun 09, 2016 - 10:53 MDT