To view uptime history for your instance of Canvas, click here.

Intermittent Document Preview Error in Canvas
Incident Report for Instructure
Resolved
Users should no longer experience an intermittent error when trying to preview documents within Canvas, but we will continue to monitor this issue. Thank you for your patience.
Posted Nov 03, 2016 - 09:46 MDT
Investigating
We're investigating reports of an error generated by the Document Previewer in Canvas with our partner company. We apologize for any inconvenience and will post further updates as soon as is possible.
Posted Nov 03, 2016 - 09:26 MDT