To view uptime history for your instance of Canvas, click here.

Import/Export Slowness
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 24, 2017 - 13:28 MDT
Monitoring
The Engineering and Operations team have implemented a fix to the way jobs process. This fix has been running and has improved the wait time considerably. We will continue to monitor and provide updates as they become available.
Posted Apr 24, 2017 - 11:48 MDT
Update
The Engineering and Operations team have identified the cause of the issue and are taking steps to alleviate the pressure on the system. This is a process by which asynchronous jobs (e.g. grading, notifications, SIS imports) are migrated from one processing node to another in order to “cool” any “hotspots” that may have formed. This is a “auto-manual” process, which takes some time, as moving live data around requires a steady hand.
Posted Apr 24, 2017 - 10:04 MDT
Investigating
Jobs related to Canvas imports and exports are backed up, for some users, at this time. We are investigating the cause and will provide updates every 30 minutes.
Posted Apr 24, 2017 - 08:30 MDT