To view uptime history for your instance of Canvas, click here.

All Canvas users are currently experiencing slowness
Incident Report for Instructure
Resolved
The issue has been resolved and Canvas is functioning as it should again. Our DevOps team is working on a long term strategy to help prevent further issues that could stem from managing load distribution across Canvas.
Posted Feb 02, 2015 - 13:55 MST
Monitoring
Our DevOps team has identified that the problem is stemming from the resource that manages load distribution across Canvas. They are hard at work getting it fixed.
Posted Feb 02, 2015 - 13:04 MST
Investigating
All Canvas users are currently experiencing slowness. Our DevOps team is working on it, and we'll provide an update in 15 minutes.
Posted Feb 02, 2015 - 12:45 MST