To view uptime history for your instance of Canvas, click here.

Intermittent slowness for some users
Incident Report for Instructure
Resolved
Our Ops team was able to identify and correct the problem causing the slowness, all instances of Canvas are back to normal operation.
Posted Dec 14, 2016 - 18:50 MST
Investigating
Some users are reporting slowness and page errors while accessing Canvas, our Ops team is investigating and we will provide and update in 15 minutes.
Posted Dec 14, 2016 - 18:34 MST