To view uptime history for your instance of Canvas, click here.

Some users experiencing page time outs while trying to access Canvas.
Incident Report for Instructure
Resolved
Page load times have returned to normal.
Posted Dec 01, 2017 - 08:49 MST
Investigating
Some North American users are experiencing time out issues when trying to load pages within Canvas that is generating page errors. Our DevOps team is investigating the issue currently.
Posted Dec 01, 2017 - 08:36 MST