To view uptime history for your instance of Canvas, click here.

Cluster 27 Sever Degrading Performance
Incident Report for Instructure
Resolved
Our slave database that some institutions are on failed tonight between 10:24pm and 10:30pm MST. This may have caused some issues with users using Canvas. Our Ops team was able to secure the database to function properly. We apologize for any inconvenience this may have caused for your users.
Posted Feb 25, 2015 - 23:44 MST
Identified
Severely degraded performance affecting users at some Canvas institutions very late on Wednesday, February 25, 2015
Posted Feb 25, 2015 - 23:42 MST