To view uptime history for your instance of Canvas, click here.

Files Not Processing in Crocodoc
Incident Report for Instructure
Resolved
Assignment submissions are now loading successfully in Crocodoc, if they are Crocodoc-supported file types (see our Canvas Guide at https://community.canvaslms.com/docs/DOC-2959 for more information).

Upon initial investigation, it seemed that the errors we were seeing on the back-end for Crocodoc files in Canvas were coming from the Crocodoc service itself. In working with Crocodoc (Box), they confirmed that their services were functioning appropriately. This led our engineers to verifying our settings once again. Upon doing so, they found a global required setting that had been misconfigured. With that configuration now updated, Crocodoc file preview has returned to normal functionality.
Posted Jun 16, 2016 - 15:50 MDT
Update
Crocodoc is still looking into the issue to find what is causing files not to render through their service. We will notify you once we have more information from their team.
Posted Jun 16, 2016 - 15:16 MDT
Investigating
Assignment submissions are not currently displaying in the Crocodoc view, used in SpeedGrader for teachers and submission details pages for students. Users will see these submission files displaying in a "Box" preview (you'll see the Box logo in the upper-left corner), along with the message "Crocodoc is still processing this document". We have been in contact with Crocodoc; they are looking into the issue now. We'll provide an update in the next 15 minutes.
Posted Jun 16, 2016 - 15:01 MDT