To view uptime history for your instance of Canvas, click here.

Some Users Experiencing Slowness in Canvas
Incident Report for Instructure
Resolved
A couple of Canvas institutions experienced an issue that arose from our page view database, which caused page-view-write actions on Canvas to back up. Our DevOps team was able to identify this and resolve the issue. We apologize for any inconvenience your users may have had when using Canvas during this time.

Time of Issue: 14:00-16:10 UTC
Posted Oct 26, 2015 - 11:45 MDT
Investigating
Users at some institutions are seeing slowness when they attempt to access Canvas. Our Dev Ops team is actively working to address the issue. We apologize for any trouble this is causing for these users. We will provide an update once we have more information.
Posted Oct 26, 2015 - 08:33 MDT