To view uptime history for your instance of Canvas, click here.

A small number of users are experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Our DevOps team identified an issue affecting one of our servers between 1:26PM to 1:53PM, and then again from 2:11PM to 2:25PM MDT. During that time, affected individuals may have experienced timeouts and page errors. All servers are now operational and thank you for your patience.
Posted Nov 08, 2016 - 18:07 MST
Identified
Our DevOps has identified an issue currently affecting one of our servers. Affected individuals may have experienced timeouts and page errors. Our DevOps team is working to resolve the issue. This incident seems to be affecting 1% of our Canvas users.
Posted Nov 08, 2016 - 14:43 MST