To view uptime history for your instance of Canvas, click here.

Users at a few institutions not able to access Canvas
Incident Report for Instructure
Resolved
Users at the institutions affected by this problem can now access Canvas again. The incident began at about 10:15 AM Mountain Time and was resolved at approximately 10:20 AM Mountain Time. We apologize for the trouble!
Posted Sep 21, 2015 - 10:23 MDT
Investigating
Users at a small percentage of Canvas institutions are not able to access Canvas currently. Our DevOps team is fixing the problem; we'll provide an update in the next ten minutes.
Posted Sep 21, 2015 - 10:21 MDT