To view uptime history for your instance of Canvas, click here.

Media recording, uploading, and playback degraded for some users
Incident Report for Instructure
Resolved
Our engineers have resolved the problem that was preventing some users from recording, uploading, and playing back media in Canvas. We apologize for the frustration this caused affected users. We'll provide an incident report for Canvas admins in the next 24 hours describing what happened, what we did to fix the problem, and preventative measures we'll take against future similar incidents.
Posted Sep 29, 2014 - 16:41 MDT
Identified
Our DevOps team has identified the root of this issue and is working on a solution. We appreciate your patience!
Posted Sep 29, 2014 - 15:29 MDT
Investigating
Some users are seeing errors and delays as they attempt to record new video, upload video, and view previously recorded / uploaded videos in Canvas currently. We apologize for the hassle. Our engineers are working on a solution right now.
Posted Sep 29, 2014 - 14:46 MDT