To view uptime history for your instance of Canvas, click here.

Password reset is not working
Incident Report for Instructure
Resolved
Password reset is working as it should.
Posted Nov 08, 2014 - 15:44 MST
Monitoring
A fix is being deployed.
Posted Nov 08, 2014 - 15:01 MST
Identified
Password reset is not working.
Posted Nov 08, 2014 - 14:37 MST