To view uptime history for your instance of Canvas, click here.

Some Users Experiencing Slowness in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has verified that performance is stable once again for Canvas sites that were experiencing slowness between 11:28 AM and 1:40 PM Mountain Time. They are implementing improvements that should help prevent this type of slow performance from occurring in the future. We appreciate your patience during this time and apologize for any inconvenience that this has caused.
Posted Sep 16, 2015 - 14:31 MDT
Monitoring
Our DevOps team has restored performance for institutions that have been experiencing slowness and page errors. However, they are still looking into the root cause to verify all is fixed. It is working now for users, but may occur again until this is verified. We appreciate your patience during this time. We will provide more information as soon as we can.
Posted Sep 16, 2015 - 14:04 MDT
Identified
Users at some institutions are seeing slowness and page errors when they attempt to access Canvas. Our Dev Ops team is actively working on a fix to address the issue. We apologize for any trouble this is causing for these users. We will update this page once we have more information.
Posted Sep 16, 2015 - 11:50 MDT