To view uptime history for your instance of Canvas, click here.

Google LTI may be inaccessible for some users
Incident Report for Instructure
Resolved
Our Operations team was able to locate the cause of this behavior and implement a solution. Again, we apologize for any inconvenience this may have caused your users.
Posted Jan 17, 2018 - 20:45 MST
Investigating
Some users may be experiencing blank pages when accessing Google LTI in Canvas. Our engineers are aware of the issue and currently working to resolve it as soon as possible. We apologize for the interruption and appreciate your patience.
Posted Jan 17, 2018 - 19:33 MST