To view uptime history for your instance of Canvas, click here.

Phone System connection issue
Incident Report for Instructure
Resolved
We are no longer experiencing delays with our system. Our phone service is back to normal. We apologize for the inconvenience and appreciate your patience.
Posted Jan 18, 2018 - 10:43 MST
Investigating
We are currently experiencing a service interruption with our phone system. We are still able to accept incoming calls, but there is a minor delay while answering. We are working with our IT department to correct the issue. We apologize for the inconvenience and we appreciate your patience.
Posted Jan 18, 2018 - 10:12 MST