To view uptime history for your instance of Canvas, click here.

Previews slow to load or not available for some documents in Canvas
Incident Report for Instructure
Resolved
Performance has returned to normal. Users should no longer experience issues when trying to preview documents in Canvas. Thanks once again for your patience, and we apologize for any inconvenience this caused for you or your users.
Posted Aug 22, 2016 - 16:27 MDT
Update
We are still showing delays in document previews. We will continue working with Box to complete the processing for the documents that are experiencing these delays. For users who do not see document previews, we recommend checking back periodically as we work to push those through. We will continue to monitor progress and update you again by the end of the day.
Posted Aug 22, 2016 - 12:48 MDT
Update
There is progress with the number of documents being processed. We are still working with Box, our partner to continue to improve load times for your documents.

We will continue to monitor the progress with this issue. We will update you again in an hour or less.
Posted Aug 22, 2016 - 11:31 MDT
Identified
Some document previews in Canvas are loading slowly currently; users see the "unicycle panda" waiting indicator when trying to preview the document. Other document previews are not loading at all, and users see a message indicating "the service is not available right now; please try again later" message where the preview should appear. Both of these issues are caused by heavy volume on our document rendering service presently. We have increased capacity on the Canvas side of the document-rendering service, and we're working with Box, our partner, to get capacity added on their side, too. Right now, the limitation is on the Box side.

This issue is only affecting documents that have not been rendered previously. Once a render appears for a given document for any user, it will appear for all users trying to access the same document. We apologize for the trouble; we'll post updates every half hour as we work to improve turnaround time on renders.
Posted Aug 22, 2016 - 10:35 MDT