To view uptime history for your instance of Canvas, click here.

Beta not accessible
Incident Report for Instructure
Resolved
Beta instances of Canvas are accessible again for all users with beta access. We apologize for the trouble!
Posted Jul 29, 2015 - 11:24 MDT
Investigating
Users aren't able to sign into beta instances of Canvas currently. (Production instances of Canvas are working normally.) We apologize for the trouble, and our DevOps team is looking into it. We'll provide an update as soon as they've identified the issue.
Posted Jul 29, 2015 - 08:13 MDT